Issues with providers accessing telehealth meetings

Incident Report for Wellpro

Monitoring

A hot fix has been deployed and will monitor the results
Posted Jun 18, 2026 - 22:28 EDT

Identified

The issue has been identified and a fix is being deployed
Posted Jun 18, 2026 - 22:26 EDT

Investigating

Some users report issues with joining telehealth video meetings.
Posted Jun 18, 2026 - 15:00 EDT
This incident affects: Wellpro Intelligent Health Record.